FANDOM


This tutorial does not use images from the latest version of GIMP. Screenshots may be outdated.

GIMP, short for GNU Image Manipulation Program, is a popular free, open-source image editor. It is available for Windows, OS X, and Linux, and requires less resources than editors like Photoshop. The program is known for a steep learning curve but offers a wide range of functionality, with new plugins constantly being developed by its userbase. This line of tutorial pages is planned to explain the various tools and filters, how selections, layers, and masks work, tips for making art in GIMP, and more.

Before you start experimenting with GIMP, it may be wise to create a completely new image by pressing File > New or
Ctrl
+
N
. You can also import an existing image using the top section of the File menu, or with standard keyboard shortcuts like
Ctrl
+
O
.

The absolute basics

GIMPToolboxToolOptionsLayers

A Toolbox - Tool Options - Layers setup

Many of the basic concepts in GIMP are easier to figure out when you have the Toolbox open. To open the Toolbox, press Windows > Toolbox or
Ctrl
+
B
.

The Toolbox contains all of GIMP's basic tools, the color switcher, and other dialogs, such as Tool Options, represented as dockable tabs.

A simple configuration of Toolbox, Tool Options, and Layers will work well for this tutorial. To open Layers, press Windows > Dockable Dialogs > Layers or
Ctrl
+
L

Layers

GIMPLayers

The Layers dialog, with many layers. Layers are ordered from top to bottom.

In GIMP, images are represented as series of layers. You can think of a layer as a transparent sheet of paper. You can draw on the layer, but depending on its properties and content, parts of the layers below may be visible.

Layers also don't have to be the size of the image; their layer boundaries can be bigger or smaller, and positioned anywhere in or outside of the image. (Only layer content within the image boundaries, or the canvas, will be visible.)

So instead of thinking as a GIMP image as a paper with a picture on it, think of it more as a stack of transparency papers, with pictures on each of them, and all within a frame.

You can create a new layer using Layer > New Layer... or
Ctrl
+
Shift
+
N
, but the quickest way may be to
Shift
+click the page icon at the bottom of the Layers dialog. Usually, exporting an image from GIMP using File > Export or
Ctrl
+
E
results in a flattened file without any layer data. To save the image as a collection of layers that can each be operated on later, save it in GIMP's native XCF format: press File > Save As or
Ctrl
+
Shift
+
S
, and make sure that .xcf is the file extension.

Channels

A Channel is a component of a layer that determines an aspect of its pixels' colors, put on a scale from 0 (completely dark) to 255 (completely bright). These will almost always be Red, Green, and Blue, which can be mixed on a computer screen to create any other color.

A Channel you may not be as familiar with is Alpha, which determines opacity. This represents how transparent a pixel is, on a scale from 0, completely transparent, to 255, completely opaque. You can see lower layers through translucent pixels.

Alpha is useful to work with, but layers don't necessarily have this Channel. In the Layers dialog, layers with bold names have no Alpha Channel. To add it, right-click the layer name, then press Add Alpha Channel.

A region that is translucent on all layers will show a dark checkerboard pattern. GIMP uses this pattern to represent transparency. The checkerboard pattern will not appear if the image is exported.

GIMPMask

A layer with a custom mask.

You can restrict the maximum value of a Channel using masks. To add a mask for a layer's Alpha Channel, right-click the layer name, then press Add Layer Mask.... You can then edit the mask.

Switch between editing a layer and its mask by clicking their icons in the Layers dialog. The layer mask is to the right, and is always represented in grayscale.

Selections

GIMPSelection

An image (200% zoom) with a color-based selection. Look for the marching ants at full size.

When you want to edit a specific phrase in a word processor, such as Microsoft Word, you highlight the phrase to select it before you use the command. This is similar to how selections work in GIMP, but it works on pixels instead of letters. To put selections in the simplest possible terms:

If a selection exists, actions on the layer will only be applied to the selected region.

Selected regions don't need to be contiguous. Some tools allow you to hold
Shift
to add to the selection, or
Ctrl
to remove parts of it, letting you select two or more separate parts of an image.

Example uses of selections are creating a selection to limit where you can paint onto a layer; selecting parts of a layer, switching layers, then filling the selection on the other layer; and limiting the parts of an image that filters can affect.

When you select part of an image, the selection has a moving dashed line around it, called the marching ants. To show and hide the marching ants, press View > Show Selection or
Ctrl
+
T
. You will usually want them to be shown. You can also draw on and edit the selection directly by pressing Select > Toggle Quick Mask or
Shift
+
Q
, where selected regions appear unaltered, and unselected regions have a red filter over them.

Selections are a bit more complicated than the simplest possible terms suggest, as the selection is really just a special temporary Channel. This means that you can give pixels a varying degree of selectedness, from 0, unselected, to 255, completely selected. The marching ants are a contour line at 50% selectedness. Actions on partially selected pixels only applied to the degree that they are selected.

Don't worry if this seems a bit confusing; the most basic selection tools use all-or-nothing selection by default.

Selection is an important concept to understand, so try to familiarize yourself with the options under the Select and Tools > Selection Tools menus. To clear your selection, press Select > None or
Ctrl
+
Shift
+
A
.

Undoing

The greatest boon of making art digitally is that you can undo mistakes. In GIMP, even selections can be undone. To undo the latest action, press Edit > Undo or the standard
Ctrl
+
Z
. To redo an undone action, if no other action has occurred since undoing it, press Edit > Redo or
Ctrl
+
Y
.

The length of the Undo History is limited by device memory, and you will have less undos after large operations. However, you will usually have at least two or three undos to work with.

An image's Undo History will be lost if it is closed. There are also certain operations that can't be undone. Be careful and consider working on a duplicate of your image if you want to try something risky. To duplicate an image, press Image > Duplicate or
Ctrl
+
D
. Undo History doesn't copy to the duplicate, so only work on the duplicate until you're sure of what you're doing.

Pasting

A quick but vital note on pasting images into GIMP is that doing so will not paste an image immediately. Instead, GIMP creates a Floating Selection, allowing you to move the content around before committing to the paste, but barring you from most actions.

To merge the Floating Selection onto the previously active layer or mask, press Layer > Anchor Layer or
Ctrl
+
H
. To paste the Floating Selection into a new layer, press Layer > To New Layer or
Ctrl
+
Shift
+
N
.

Tools

GIMPTools

The tools offered in the Toolbox.

In this section, many of GIMP's various tools, and their functions and categorizations, will be discussed.

The Toolbox contains a pair of boxes containing the current foreground and background colors. You can click on a color to open a dialog to change it. Many other tools allow you to hold
Ctrl
to use the background color instead of the foreground color. To swap the foreground and background colors, press the double-arrow icon, Tools > Swap Colors, or
X
. The default colors are black and white, in the foreground and background, respectively. To reset the colors to these defaults, press the icon of black and white squares, Tools > Default Colors, or
D
. Other than this, you can find many tools both through the Toolbox, the Tools menu, and keystrokes that sometimes use the
Shift
key.

The Notes column gives some useful tips relevant to the tools, but it is not a comprehensive list of functionality. Try holding down different modifier keys or scrolling through the Tool Options dialog to find other options.

ToolKeystrokeTools menu categoryDescriptionNotes
Rectangle Select
R
SelectionSelect a rectangular region by dragging between opposite corners.
  • Shift
    +drag to add to the selection.
  • Ctrl
    +drag to remove from the selection.
  • Hold
    Shift
    mid-drag to lock aspect ratio.
  • Hold
    Ctrl
    mid-drag to center the selection.
  • The shape can be resized after the initial selection.
  • Drag and hold a shape and read the status bar to measure horizontal or vertical distances without switching tools.
Ellipse Select
E
Select an elliptical region by dragging between bounds.
Good for approximating rounded edges.
Free Select
F
Select a hand-drawn region with free and polygonal segments.
  • Shift
    +drag to add to the selection.
  • Ctrl
    +drag to remove from the selection.
  • Release and click to create line segments.
  • Release and hold
    Ctrl
    to constrain segment angles.
Fuzzy Select
U
Select a contiguous region on the basis of color.
  • Shift
    +drag to add to the selection.
  • Ctrl
    +drag to remove from the selection.
  • The Threshold option is useful for adjusting the tool's sensitivity.
  • Set Threshold to 0 to select only a specific color.
  • Drag to adjust the threshold mid-selection.
  • The Select by option changes the component used to compare.
By Color Select
Shift
+
O
Select regions with similar colors, regardless of their contiguity.
Good for editing all matching pixels at once.
Bucket Fill
Shift
+
B
PaintFill selected area with a color or pattern.
Good for coloring line art.
  • Shift
    +click to fill the entire selection, regardless of threshold.
  • The Fill Type option changes the color used to fill and allows you to fill with a pattern.
  • The Threshold option is useful for adjusting the tool's sensitivity.
  • Set Threshold to 0 to fill a contiguous region of only a specific color.
Blend
L
Fill selected area with a color gradient.
  • Hold
    Ctrl
    mid-drag to constrain gradient line angles.
  • Hold
    Alt
    mid-drag to move the gradient line.
  • The Gradient option changes the colors used in the gradient.
  • The Shape option changes the type of the gradient, e.g. linear or radial.
Pencil
N
Hard edge painting using a brush.
Good for pixel art.
  • Hold
    Shift
    to draw a line segment from the end of the last stroke.
  • Press
    Ctrl
    to pick the foreground color without switching tools.
  • The Brush option determines the shape painted with.
  • The Size option changes the brush size.
  • Press
    [
    and
    ]
    to change the brush size by 1.
  • The Smooth stroke option helps remove the shakiness from paint strokes, can give your brush a realistic feeling of inertia and friction, and can be extremely helpful for painting.
Paintbrush
P
Paint strokes using a brush.
Eraser
Shift
+
E
Erase to background or transparency using a brush.
Airbrush
A
Paint using a brush, with variable pressure.
Good for shading.
Smudge
S
Smudge selectively using a brush.
Align
Q
TransformAlign or arrange layers and other objects.
  • Shift
    +click or
    Ctrl
    +drag to pick multiple objects to align.
  • The Relative to option describes the reference object layers will be aligned to.
  • The First item setting of Relative to acts the same as the Image setting when only one object is picked.
Move
M
Move layers, selections, and other objects.
  • Press the arrow keys for pixel-by-pixel movement.
  • Hold
    Shift
    and press the arrow keys for large movement relative to the zoom level.
  • If a layer isn't moving, check whether the Move option is set to Layer.
Color Picker
O
N/ASet colors from image pixels.
  • Ctrl
    +click to set the background color.
  • The Sample merged option selects the color generated by stacking all the layers, instead of the color on the current layer.
Zoom
Z
Adjust the zoom level.
  • Ctrl
    +click to zoom out.
  • Drag to zoom a specific rectangle of pixels to the window.
  • Use View > Zoom > Revert Zoom or
    `
    to return to the previous zoom level.
  • Use the second section of View > Zoom or the number keys to adjust the zoom level to specific percentages without switching tools.
  • Press
    -
    and
    Shift
    +
    =
    to zoom out and in, respectively, without switching tools.
Text
T
Create or edit text layers.
  • Drag to draw a new frame and set the Box option to Fixed.
  • The frame can be resized.
  • Use the text toolbar or the Tool Options dialog to change text style.
  • Press
    Esc
    to exit the textbox, for instance, if you want to use a keystroke instead of typing.
  • Use the Layer menu for extra commands on text layers.
Community content is available under CC-BY-SA unless otherwise noted.