FANDOM


GIMP may be a free program, but it has all the primary tools needed to make great art! People have different styles they like to use when making art, so I will make this tutorial as open-ended as possible, with many different strategies for completing the basic steps of art production. Hopefully you'll find one that works for you!

Note that this tutorial is a basic overview of the art creation process in GIMP - if all you want is to look up what a particular tool does, this tutorial may be better for you. If you still don't find what you're after, try the official GIMP online manual - the current version (as of August 2018) can be found here.

Note - my tutorial uses screenshots from the Mac version of GIMP. The Mac and Windows versions of GIMP are essentially the same, so this tutorial should work regardless of your operating system. For any shortcuts that use the Command "Cmd" key, windows users should use the Control "Ctrl" key instead.

Importing Images and Sketches

It is possible to create digital art without needing to touch pen and paper, but many digital artists sketch their pieces on paper first. If you'd rather not use a sketch, you can skip down to Lineart and Freestyle Drawing. For the rest of you, here are two tips to remember. First, avoid adding small, excessive detail to your sketch. Second, ensure that the important parts of you sketch are drawn with clean, dark lines. These aren't essential, but will make the rest of the process a little easier.

If you have a scanner available, I'd recommend using that to import your sketches, as this ensures your work will be flat and easy to see. Otherwise, taking a picture of it on your phone will also work - just make sure the image is bright and clear. Either way, this tutorial assumes you somehow got your sketch onto your computer as an image file. Make sure you remember where it is!

GIMP Sample Sketch

For my tutorial, I'll be using this image of Kirby as an example - it's not a great sketch, but it will be good enough to work with.

GIMP Step1 GIMP Step2

Open up GIMP if you haven't already. The simplest way to import an image is to open the file directly in GIMP. Go to File > Open at the top of the window, or press Cmd + O. Use the new dialog window that has opened to locate the image of your sketch. A preview of the image should appear once you have selected it. Click Open to create the new image.

GIMP Step3

And there you go! You can begin the drawing process now if you like, but there is one more thing you can do. If the image is too dark or bold, it can be hard to clearly see what you are drawing. One way to solve this is to create a new layer on top of it. Create a new layer by clicking the new layer button on the layers tab, or with the shortcut Cmd + Shift + N. Set the new layer to have a white fill, and press Enter.

GIMP Step4 GIMP Step5

Your image may look like a blank white sheet, but don't worry - this is part of the plan. Adjust the opacity of the layer in the layers tab. 50% or so should work.

GIMP Step6

Now if you need to see more or less of your sketch, simply adjust the opacity of this layer. Now that your sketch is imported, let's move on to the drawing portion.

Lineart and Freestyle Drawing

Many forms of digital art use outlines prominently. Especially for beginners, using lineart effectively can make it easier to create professional looking art! If you own a drawing tablet this portion may be easier for you, but I will cover techniques to draw using a mouse as well.

There are two main ways to draw lines in GIMP: pencils and paths. The pencil tool are likely more familiar for new artists, especially if you have used Microsoft Paint in the past, so I'll cover it first.

Pencils and Ink

The first thing you will want to do is create a new layer to draw on. Press Cmd + Shift + N, but this time select a transparent fill for the layer. This is the layer that the lineart will be on. A good way to remember this is to rename the layer - simply double-click the layers name on the right, and enter any name you want.

GIMP Step7

Now its time to choose which tool you want. There are two tools that work well for drawing lines - the Pencil and the Ink (the Paintbrush can work too, but is a little more complicated). The basic difference is that Pencil lines have rough edges and Ink lines have smooth ones. If you opt for the Pencil the coloring process is easier, but the Ink tool makes nicer looking lines. Use the Tool Options menu to choose how thick you want your line to be. Remember that you can increase or decrease the size of you pen by pressing [ or ].

GIMP Step8

If you are drawing with a tablet, this part is quite simple: just trace your sketch with your tool of choice. If you are using a mouse, this can be a challenge, but there is a setting that will make the task much easier - Smooth Stroke! While immensely beneficial for mouse artists, it can help tablet users as well!

With the Smooth Stroke setting enabled, the pen will no longer follow your cursor directly. Instead, it will lag behind a little, and it won't change direction as sharply. The higher the quality setting, the less shaky the line will be - the higher the weight setting, the slower the pen will move. Play around with these two settings until the pen works the way you want it to. The picture includes the settings I used. (Note that Smooth Stroke is automatically enabled for Ink, but not for Pencil). For the sake of example, I will be drawing the lines using my Mac's trackpad, rather than my art tablet.

GIMP Step9 GIMP Step10

Note : If you are using a white layer over your sketch, as explained in the Importing Images and Layer section, take a moment to set the opacity of the white layer back to %100. Make sure to switch back to the lineart layer afterwards!

GIMP Step11

From the look of it, there are some bits of lines I should erase to clean up the image. The Eraser tool should work for fixing lines, but keep in mind that pencil and ink lines aren't the same, so the same eraser won't work for both! Pay attention to the "Hard Edge" setting for the Eraser - it should be checked if you drew your lines with Pencil, but not if you used the Ink.

GIMP Step12

And there it is, a complete outline! That may have been a little tedious, but the end result isn't half bad. There is another way to create outlines though...

Paths

Paths can also be used to create outlines. Rather than drawing the lines in real-time, the path tool is used to predefine the areas where lines should be. Think of it like telling the computer where you want you lines to go - the computer is much more precise than any human hand, so it can do the job easily. The process of telling the computer where to put the lines can be trick to learn, but once you know it it's a breeze - especially compared to drawing with a mouse!

The first thing you will want to do is create a new layer to draw on. Press Cmd + Shift + N, but this time select a transparent fill for the layer. This is the layer that the lineart will be on. A good way to remember this is to rename the layer - simply double-click the layers name on the right, and enter any name you want (Since I already drew the lines by hand, I'll create a second lineart layer).

GIMP PStep1

Now you should open up the paths tool on the right. It's the one with the yellow-tipped fountain pen connected to a weird line with knobs on it. You can also select the tool by pressing B. To start laying down a path, click on where you want a line to start. A dot should appear where you click - these are called nodes. The path will travel through every node assigned to it. Once you have placed a node, you can move it around by dragging it with the mouse. Place a second node somewhere else on the line - let's say you place nodes like this:

GIMP PStep2 GIMP PStep3

That looks about right, but Kirby's face is round, not angular. You could try to create a smoother line by adding more nodes, but there's a better way. Hold the Cmd key and drag on one of the nodes:

GIMP PStep4

The node itself won't move this time - instead, a second, square node appears, attached to the original with a yellow line. These square nodes are called handles - each node has two handles, since the path passes through it on both sides. Notice that the line to the left of the node is now curved, not straight. When a path passes through a node, it will try to line up with the handle. Hold the Cmd key again to drag out the other handle, and line it up opposite the first one:

GIMP PStep5

When laid out in this way, the handles will create a smooth curve centered on the node. Stringing many such nodes together can create very accurate curves, as seen in the image below. Notice that some nodes are placed at corners rather than along curves - these nodes have handles that are not aligned, or the handles where not moved from their default position.

GIMP PStep6

Another way to adjust handles is by dragging a path segment directly. This can be used to quickly outline Kirby's feet. Create two nodes on either side of Kirby's foot. Click and drag the segment between the nodes outwards - it will automatically create a curve! You can move the handles to adjust the path further.

GIMP PStep7 GIMP PStep8

Now outline the entire image with you path. To create a node that isn't connected to the rest of the path hold Shift before clicking. To connect a node to another one, click on one node, hold Cmd, and click on the other one. A node can, at most, be connected to two other nodes.

GIMP PStep9

Now all the lines are set, but we still need to tell the computer which tool to outline the image with. I will be using the Pencil tool, since I used the Ink to draw by hand earlier. Now click on the Pencil tool and-

GIMP PStep10

-wait, what happened to my path?! I'm embarrassed to admit it, but I was convinced that paths were deleted the moment you were done using them. Turns out, this isn't the case! Go to the paths tab at the top right, in the same place as layers. You path should be right there!

GIMP PStep11

Paths are automatically set to become invisible when you don't have them selected, and switching away from the path tool will deselect the path you were working on. Click on the first checkbox from the left, and an eye should appear. You path should also be outlined, likely in blue.

GIMP PStep12

Anyway, back to what I was saying. Select the Pencil or Ink tool, and set it up as described above in the Pencils and Ink section. Once you have done that, it is finally time to draw the outline! Go back to the paths tab, and click on you path. At the bottom, click on the second-to-last button to "Paint along Path". You can also go to Edit > Stroke Path on the bar at the top.

GIMP PStep13 GIMP PStep14

This new window will let you select the tool you want. You can use the default "Stroke line" if you prefer - it draws a smooth line not unlike the Ink, and you can set it up to use a dashed line. However, I recommend using the "Stroke with a paint tool", since it uses the exact same tools I'd have used to draw by hand. Don't worry about the brush dynamics checkbox, just leave it unchecked. Once you click stroke...

GIMP PStep15

...the end result is this nice, clean outline! It may take some time to set up, but the path tool is incredibly versatile!

Of course, you can use both of these options if you prefer. If a particular curve is too difficult to draw with a mouse, or even with a tablet, using a path could be the quick and easy solution! Now that the lines are finished, it's time to start shading in the piece.

Coloring Techniques

So you managed to get the lineart completed. Great Job! If you did it right, the most difficult part is over. Just as before, there are a few different tools you can use to color in your piece: the two I used most often are the Paint Bucket and the Select Tool. The Paint Bucket is much faster and simpler if you created your lines with the Pencil, while the Select Tool is faster to use on Ink lines. Since I have both types of line in my document, I'll color the image twice with both methods.

An important first step for both methods is to create a separate layer for the colors to be placed on - there is nothing worse than painstakingly shading for 30 minutes only to find you used the wrong layer! I'd even go so far as to suggest you save a new file when starting this process.

Gimp CStep1

I will create two layers for color - one titled Color (Paint) and the other Color (Select). That way, we can directly compare the two coloring methods!

Paint Bucket

Gimp CStep2

With the Pencil outline already visible, we can get into the simple Paint method! The Paint Bucket should be an easy tool to find, or you can use Shift > B to select it.

Gimp CStep3

Take a second to set up the paint tool with these parameters. Remember that the both the "Fill Transparent Areas" and "Sample Merged" options should be checked. This tells the tool to paint on the current layer (even if no colors exist there yet), and to stop at a line (even if the line is not on the current layer).

Gimp CStep4 Gimp CStep5

Select the color you want to fill in with - in this case, it's just pink. Click the current dialog box, and select the new color you want. The bar on the left of the box controls the hue you are currently using, and the box itself controls determines the lightness, darkness, and saturation of that hue. You can also control the values directly using the sliders, but I usually don't.

Gimp CStep6

Now it's as simple as clicking the areas you want to fill in! Here I've shaded the areas of pink on Kirby already. Note that I had to fill Kirby's body and right hand separately since a black line runs between them. I'll go ahead and color the rest the same way.

Gimp CStep7

There we go - the coloring process is finished! A quick word on colors - notice how Kirby's eyes are colored "black" and "white". That's "black" and "white" in quotations because I never color in with pure black or white - here I used very, very dark red and very, very light grey. This is to avoid confusing black filled areas with the black lineart, and white filled areas with the background. It's a habit I picked up from my (very short) time working on digital sprites, but it works here as well.

Select Tool

Now suppose you used the ink tool to draw your lines - why can't you just use the bucket here as well? To see why, let's try and fill in this lineart of Kirby with the Paint Bucket ... after switching to the a layer, of course!

Gimp CStep8 Gimp CStep9

Do you see the problem? Here, let me zoom in for you:

Gimp CStep10 Gimp CStep11

See it now? The point where the fill and the lines meet is separated by these ugly grey specks! When compared to the seamless fill achieved with pencil lines on the right, the difference is quite stark.

Gimp CStep12

Now, you could go along each line and fill those blank spaces with color, using either the ink or the pencil. Look how much better that looks on the left now! The problem with that is the time required to do so - feasible for a simple image like this that uses only a few colors and lines, but it isn't practical for anything more than that.

That is where the select tool becomes handy! Let's erase the color I just put down and see how this method makes it so much easier.

Gimp CStep13

The tool we want to choose is the Fuzzy Select tool, AKA as the "Magic Wand". You can select it by pressing U. Not sure why it's U, but just go with it. The settings for Fuzzy Select (which I'll just call the "Select" tool from now on) should be the same as the Paint Bucket from before - make sure both the "Fill Transparent Areas" and "Sample Merged" options are checked.

Gimp CStep14

Now begin selecting the various regions you want to color. To select multiple areas at once, hold the Shift key as you click in each region. You should see these dotted lines, called the "marching ants", outlining your selection. (These are much easier to see if you view each image at full size!)

Gimp CStep15

If we zoom in real quick, you may notice that the selection does not include the grey areas that were missed by the Paint Bucket before! If we fill in the selection as is, we will get the same result as before. We will need to expand the selection first.

Gimp CStep16 Gimp CStep17

Go to the select menu, at the top of the screen, and select the Grow option. From here, choose how many pixels larger the new selection should be. 2 pixels has worked in most cases, but it depends in part on how thick your lines are - as long as it partially overlaps the line without extending past it, your good.

Gimp CStep18 Gimp CStep19

Notice how the dotted lines now lies on top of the lineart instead of inside it. This is exactly what we want! Now switch over to the Fill Bucket Tool to fill in this selection. Set it up the same way as the above section describes, except for one thing - deselect the Sample Merged check box. We don't want our selection to stop at the paint lines anymore, we want to fill the entire selection!

Gimp CStep20 Gimp CStep21

With that quick alteration, click inside the selection to fill the new region! Notice that this time, both Kirby's hand and body are shaded at the same time. And if we zoom in, those pesky gray specks are gone, too! I'll go ahead and finishing coloring Kirby in.

Gimp CStep22

There we go - Kirby has been successfully colored in again! Now, there is one little problem with this coloring method. Let's zoom in really close to Kirby's eye:

Gimp CStep23

One little grey speck on the right managed to escape! This is common in places where two outlines meet at a sharp angle - if it is sharp enough, a sizable chunk could be completely uncolored! The only solution I have is to color these spaces in manually if they are noticeably large - otherwise, you can ignore them if you don't wan't to bother shading them in. In this case it is nigh impossible to see when viewing it regularly, so I won't bother fixing it. Let's quickly compare our two versions side by side:

Gimp CStep24 Gimp CStep25

Both came out pretty good! I will be working with the one on the left for the shading process because I like its clean look a little more. Shading can be a bit tricky, so be sure to safe a backup version of your art the first few times you tackle it!

Shading and Highlighting

GIMP SStep1

We left off with this image of Kirby. I deleted the other lineart and fill to simplify the layers section - this is what it would usually look like, anyway. The important consideration for shading is preserving the original colors - if something goes wrong in the shading process, or you want to change one of the base colors, keeping the original color layer intact makes it much easier to alter things later.

There are two ways I usually do this - either create a new, transparent layer for the shading, or duplicate the colors layer, hiding one and shading the other. Which you choose is depends on the specifics of your project - I'd recommend the latter if you know you will recolor the subject a lot, such as for alternate colors in a fighting game. I'll go over only the second one, since it is more versatile and slightly more complex - if you understand how to use it, you will be able to use the first as well!

GIMP SStep2

To start, let's create a new transparent layer, titled Shading. The placing is very important - it must be beneath the lineart layer, but above the color layer.

GIMP SStep3

Next, let's cover how to select the area to color. You could use the Select tool from before, but in this case the Color Select tool is a better choice. It is right next to the Select tool, and can be chosen with the keyboard shortcut Shift > O. This tool selects every region on screen that shares the same color - since we will be shading one color at a time, this is very convenient!

How you use it depends on both the type of line / coloring you used previously and the shading method you are currently using.

  • If you used pencil lines for the lineart, simply set the Color Select to "Sample Merged", and select the color you want.
  • If you used Ink lines and are shading a duplicate color layer, turn off "Sample Merged", and select the color you want.
  • If you used Ink lines and are shading a transparent layer over the original color layer, keep "Sample Merged" on, but hide the lineart layer before you create your selection. It may look weird without outlines, so reveal the lineart layer occasionally to see how things are progressing.

No matter which method you are using, be sure to NOT shade the original color layer by accident! Even though I don't need to, I'll use the third shading method - it's a little complicated, so it's important I show how to use it.

GIMP SStep4 GIMP SStep5 GIMP SStep6

Notice how I have the blank shading layer selected the entire time, but still have a selection containing only the pink region from the lower layer! Now that the selection is made, the last part is the shading tool you will use. You can use any of the previous tools covered - the Pencil, Ink, even the Paintbrush if you feel like it - but for smooth, natural shading, nothing beats the Airbrush!

GIMP SStep7 GIMP SStep8

The airbrush lays down clean, gradient-like shades easily. It is also easy to setup - select the Circle Fuzzy brush from the menu (it looks like a soft, circle-ish shadow), and set the brush size you want (remember you can use [ and ] to change the brush size!).

GIMP SStep9

If you want to control how quickly the airbrush shades, you can change the flow. The higher it is, the faster the image will be shaded. The number doesn't have to be very high to get a decent shading speed, so don't over do it!

GIMP SStep10

Here is a very simple shade, using black for the shadow and white for the highlight. This is by far the simplest shading style, and is great for anything you know you will recolor later (that way, you only have to shade once!) But if you want to go further, here are some other shading styles!

Shading Styles

Color-Specific Shading

More a general strategy than a specific style, but worth mentioning. In general, shadows and highlights look MUCH better if you use lighter and darker shades of each color, rather than just black and white. Use the color-picker (press O to access it quickly) to change the background and foreground color to the base color you wish to shade (press X to switch foreground and background colors). Then change them to a lighter and darker shade of the color - try to keep colors at least as saturated as the base color whenever possible. Then simply shade and highlight with these new colors!

GIMP SStep11 GIMP SStep12 GIMP SStep13

Hard-Edge Shading

This is the same as the above, except using a hard tool to shade, such as Ink or Pencil. The lines must be smooth for the final product to look good, so use Smooth Stroke or Paths to your advantage! How to use these tools is described above in the LineArt section. This style can be a bit tricky, but it has worked for me before - a slightly better example is shown below, using Ink rather than Pencil.

GIMP SStep14 GIMP SStep15 AriWoman FL

Open-Border Shading

This is a really simple way to get a cool effect, similar to official Kirby art from Super Star Ultra! All you have to do is shrink the selection before shading - here, 8 pixels worked for me. Keep in mind, you want to shrink it to be smaller than the outline - if the color extends beneath the outline, you may have to shrink the selection by more. I really like this style, so this is the one I will go with.

GIMP SStep16 GIMP SStep17 GIMP SStep18 GIMP SStep19

There we have it! A fully shaded and colored image! In most cases, this will be enough work to call it a day, but sometimes you may want to go the extra mile and add even more polish. In that case, read on to the last section! If you are done here, you can simply save and export your image - go to File > Export, or press Command > E. Be sure to hide your background and sketch layers first! I usually save my files as a PNG to maintain transparency.

GIMP SStep20 GIMP SStep21

Post-Production and Effects

Assuming you've at least skimmed the tutorial up to know, you should have a basic understanding of how the most important GIMP tools work. I'll quickly cover a few easy ways to make your image look even better!

Secondary Shade

Sometimes a second layer of shading can make an image's color more vivid. For this trick to work, it's important to not overdo the shading in this step!

Gimp PPStep1 Gimp PPStep2

The idea is simple - using a new shading layer, shade over the image with the airbrush. Adjust the opacity of this layer until it looks right.

Glossy Highlight

If you look at official Nintendo artwork, you will notice subtle white shading is sometimes added to the edges of shadows. The same effect can be easily applied to your art, making it look more polished!

Gimp PPStep3 Gimp PPStep4

If you want to try this, it's very simple - just add a bit of white highlight during the shading stage. Again, the effect only works if the highlight is subtle, so don't overuse it! I've also found that the highlight is more effective if the shadow it's layered onto is darker.

White Border

This is the last post production trick I use, and the one I consider both the simplest and the most versatile. If you outlined your image in black earlier, it can be difficult to see the lines when displayed on a dark background - such as the one found here on Fantendo! The easiest solution is to add a white outline to your work to make it stand out.

Gimp PPStep5 Gimp PPStep6 Gimp PPStep7

To do this, create a new layer on the bottom of your image. Create a selection around your image, and invert it by pressing Cmd + I. Convert this selection to a path, and then stroke the selection as described above. For our purposes, a white Pencil or Ink outline works best.

You can easily use this trick in other ways as well - for instance, you can stroke with the airbrush to create a glowing effect, or convert the path back to a selection and fill it to create a quick drop shadow.

Kirby Final1 Kirby Shade2 Kirby GlossyH Kirby OutlineW

Here are the three polished versions of my Kirby image, alongside the original. Of course, you can combine these post-production effects to create an even more striking result!

Conclusion

That's about all I have for this tutorial, I hope it makes your time working with GIMP easier! One last piece of advice I'll close with is to experiment with the GIMP's tools. The best way to learn how they work is to just start using them! This tutorial is just an overview, there is lot's more to discover! Your work will improve if you continue practicing with it.

If you want to learn more about tools, shortcuts, and strategies available in GIMP, a great place to start is the GIMP online manual - the current version (as of August 2018) can be found here.
This is the Hero, signing off (talk) 1:01, August 2, 2018 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.